Resolved
We have resolved the issues causing a degraded experience for some customers in the reporting section of our Group Admin Experience.
Monitoring
We have resolved the issues causing a degraded experience for some customers in the reporting section of our Group Admin Experience.
Identified
We are still working with our cloud provider on a fix.
Identified
We have identified the issue causing a degraded experience for some customers in the reporting section of our Group Admin Experience.
We are working on a fix.