Major outage
Incident Report for DataCamp
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 19:15 UTC
Monitoring
We have implemented a solution for the issue affecting interactive coding sessions - you should now be able to complete exercises on our platform. Performance may initially be slower than normal, however, we expect this to improve in the next 10-15 minutes.
Posted Apr 21, 2021 - 18:54 UTC
Investigating
After further investigation, we have identified 2 separate problems:

- The first problem impacted several services but is now fully resolved
- A second, separate incident, is ongoing and is causing problems for users trying to obtain an interactive coding session

We are currently investigating the second problem and will report back when we have any updates.
Posted Apr 21, 2021 - 17:13 UTC
Identified
We've identified the cause of the problem - several services are fully recovered and the remaining ones should be coming back online shortly.
Posted Apr 21, 2021 - 15:40 UTC
Investigating
We are currently investigating the cause of this issue and will report back once we have an update.
Posted Apr 21, 2021 - 15:32 UTC
This incident affected: DataCamp Instructor Experience (DataCamp Content Authoring Tool - Teach) and DataCamp Learning Experience (DataCamp Main, DataCamp Courses, DataCamp Challenges, DataCamp Projects, DataCamp Videos, DataCamp Mobile & Practice, DataCamp Signal).